Report a problem
Subscribe to updates
Report a problem
Subscribe to updates
Powered by
Privacy policy
·
Terms of service
Updating Servers
Resolved
·
Full outage
Server Upgraded.
Sat, Feb 14, 2026, 12:08 PM
(
2
weeks ago)
·
View all updates
Affected components
Feb 14, 2026, 12:07 PM
12:08 PM
Pyzit
3 affected components
Sendit - Pyzit
App
Updates
Resolved
Server Upgraded.
Sat, Feb 14, 2026, 12:08 PM
Investigating
We are updating Server Resources.
Sat, Feb 14, 2026, 12:07 PM
Updating Servers - Pyzit Status